POJ 3104: Drying

POJ 3104: Drying

Problem Statement

Description

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5
Sample Output

sample output #1
3

sample output #2
2

The Algorithm

This is a classic binary search problem. Given the total wetness of the objects, we use the object with maximal wetness as the upper bound of binary search and 0 as the lower bound of binary search. We check the times for the average of the upper bound and the lower bound by simulating how drying would work with a certain time limit.
The checking algorithm considers everything from the radiator's point of view, not Jane's point of view, to optimize the process. The radiator can only be on or off at a time, so we track how many periods of time the radiator has to be on so that the time is below the limit. If the resulting time is STILL above the limit, then the limit clearly is impossible, so the upper bound becomes the value of the limit minus 1, if the resulting time is below, however, the lower bound becomes the value of the limit.

The Code


#include <cstdio>
#include <algorithm>
using namespace std;
int wetness[100001], n, k;

bool chck(int m)
{
    long long cnt = 0;
    for(int i=0;i<n;i++)
    {
        if(wetness[i]>m)
        {
            cnt += (wetness[i]-m)/(k-1);
            if ((wetness[i] - m) % (k-1) != 0)
                cnt++;
        }
    }
    return cnt <= m;
}

int main()
{
    int sum=0;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        scanf("%d",&wetness[i]);
        sum=max(sum,wetness[i]);
    }
    scanf("%d",&k);
    if(k==1)
    {
        printf("%d\n",sum);
        return 0;
    }
    int up = sum;
    int lo = 0;
    while(up - lo > 1)
    {
        int mid = (up+lo)/2;
        if(chck(mid)) up = mid;
        else lo = mid;
    }
    printf("%d\n",up);
}

Comments

Popular posts from this blog

USACO Training "subset": Subset Sums

USACO 2018 Open: Talent Show

OpenJudge 1768: Kadane's Algorithm on 2D Arrays