POJ 2352: Stars

POJ 2352: Stars

Problem Statement

Stars
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 49960Accepted: 21558
Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.
Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 
Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input
5
1 1
5 1
7 1
3 3
5 5
Sample Output
1
2
1
1
0
Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.
Source
Ural Collegiate Programming Contest 1999

The Algorithm

"Count the amount" hints that this is a BIT/prefix sum problem. Since the values are given in ascending Y order, if we process them in parallel with reading them, we don't need to consider the Y axis - we only need to consider the X axis, since there can't be any node with a Y value higher than it.
After we decide the level of the node, we increment the according index in a result array.
The Fenwick tree doesn't have any modifications: simply increment 1 for every update.

Common Pitfalls

  1. Remember that getsum() parses to the left-hand side and update() prunes to the right-hand side.
  2. Generally, while loops are good practice for BIT commands, but in some cases, for loops may be necessary.

My Code

#include <cstdio>
#define Mx 32001
#define Mn 15001
using namespace std;
int c[Mx+1], a[Mn+1];
inline int lb(int x){ return x & (-x); }
void update(int x)
{
while (x<=Mx)
{
c[x]++;
x+=lb(x);
}
}
int sum(int x)
{
int res=0;
while (x>=1)
{
res+=c[x];
x-=lb(x);
}
return res;
}
int main()
{
int n,x,y; scanf("%d", &n);
for(int i=1;i<=n;i++)
{
scanf("%d %d",&x,&y);
a[sum(++x)]++;
update(x);
}
for(int i=0;i<n;i++) printf("%d\n",a[i]);
}

Comments

Popular posts from this blog

USACO Training "subset": Subset Sums

USACO 2018 Open: Talent Show

OpenJudge 1768: Kadane's Algorithm on 2D Arrays